Jump to content
Markus

Printer Maestro Does Not Start

Recommended Posts

Markus

Hello,

 

I have installed Printer Maestro and History Explorer additionally to already working Bartender and Commander (Enterprise Automation 9.3 SR2). When starting Printer Maestro, I only see attached error message (OS: Windows Server 2008 R2 SP1 64bit). Service "Printer Maestro" is running, no entries in Event Viewer. Any idea how to solve this problem?

 

Regards

Markus

post-1708-0-04428000-1327495017_thumb.png

Share this post


Link to post
Share on other sites
Ian C - BarTender ninja @ Seagull

Firstly make sure you exit the Printer Maestro service is indeed stopped. Next open a command prompt window (DOS) and change directory to where the Printer Maestro application is installed.

 

"C:\Program Files\Seagull\BarTender Suite\Printer Maestro"

 

From this directory enter the below command to uninstall the Printer Maestro service.

 

maestro.service.exe /uninstall

 

If for any reason this doesn't seem to work, make sure the Printer Maestro application isn't running and the service is indeed stopped and try again. Once the uninstall is performed without error run the below command to re-install again.

 

maestro.service.exe /install

Share this post


Link to post
Share on other sites
Markus

I did "maestro.service.exe /uninstall" which removed the service and "maestro.service.exe /install" which created it again. After starting Printer Maestro I still get the same error popup.

 

I additionally tried on another server with Windows Server 2003 SP2 32bit, there I get following error message during "maestro.service.exe /install":

 

C:\Program Files\Seagull\BarTender Suite>Maestro.Service.exe /install

 

Running a transacted installation.

 

Beginning the Install phase of the installation.

Installing service Maestro...

Service Maestro has been successfully installed.

Creating EventLog source Maestro in log Application...

An exception occurred in the OnAfterInstall event handler of System.ServiceProce

ss.ServiceInstaller.

System.InvalidOperationException: Cannot start service Maestro on computer '.'.

The inner exception System.ComponentModel.Win32Exception was thrown with the fol

lowing error message: The service did not respond to the start or control reques

t in a timely fashion.

 

An exception occurred during the Install phase.

System.InvalidOperationException: An exception occurred in the OnAfterInstall ev

ent handler of System.ServiceProcess.ServiceInstaller.

The inner exception System.InvalidOperationException was thrown with the followi

ng error message: Cannot start service Maestro on computer '.'..

The inner exception System.ComponentModel.Win32Exception was thrown with the fol

lowing error message: The service did not respond to the start or control reques

t in a timely fashion.

 

The Rollback phase of the installation is beginning.

Restoring event log to previous state for source Maestro.

Service Maestro is being removed from the system...

Service Maestro was successfully removed from the system.

 

The Rollback phase completed successfully.

 

The transacted install has completed.

Installation Failed: An exception occurred in the OnAfterInstall event handler o

f System.ServiceProcess.ServiceInstaller.

Share this post


Link to post
Share on other sites
Shotaro I - Seagull Support

I guess it's already done - but if not, please apply .net Framework 2.0 Service Pack 2 (SP2).

If you have .net Framework 3.5 on your PC, install .net Framework 3.5SP1 which includes 2.0SP2.

Share this post


Link to post
Share on other sites
Markus

I guess it's already done - but if not, please apply .net Framework 2.0 Service Pack 2 (SP2).

If you have .net Framework 3.5 on your PC, install .net Framework 3.5SP1 which includes 2.0SP2.

On Windows Server 2003 I installed .NET Framework 2.0 SP2, but still same error during installation of Maestro Service. On the other server with Windows Server 2008 R2 .NET 3.5 SP1 was already installed.

Share this post


Link to post
Share on other sites
Shotaro I - Seagull Support

On Windows Server 2003 I installed .NET Framework 2.0 SP2, but still same error during installation of Maestro Service. On the other server with Windows Server 2008 R2 .NET 3.5 SP1 was already installed.

 

Hi Markus - I don't have a very good idea of why Service installation failed.

The error message shows Printer Maestro Service installation failed as service doesn't start within specific period.

 

There's some case .net service doesn't start in timely manner due to Certificate Revocation List check. In that case,

Disabling Local System Account's CRL check might works.

(this should have been fixed with applying .NET 2.0SP2 though)

Something like this:

 

Slow to start a app with "UIAccess = true" on Windows 2008 R2 64bit

social.msdn.microsoft.com/Forums/en-US/winserver2008appcompatabilityandcertification/thread/4f8fd6f4-f978-4478-ac15-a815d2e9ba1d/

 

Or for some reason service took too long time to start, and you need to prolong timeout.

 

A service does not start, and events 7000 and 7011 are logged in Windows Server 2003

http://support.microsoft.com/kb/922918/en-us

 

Is there any security software might block starting service? Unblock Process

"Maestro.exe" and "Maestro.Service.exe", TCP/UDP port 7170.

 

If none helps, please contact to Technical Support.

Share this post


Link to post
Share on other sites
Markus

There's some case .net service doesn't start in timely manner due to Certificate Revocation List check. In that case,

Disabling Local System Account's CRL check might works.

(this should have been fixed with applying .NET 2.0SP2 though)

This did work on our Win2003 server where installation of the service did not work (our Bartender servers do not have internet access). Thanks!

Do you also have any idea why we get this error popup (from my initial post) when starting Maestro on the Windows 2008 R2 64bit server?

Share this post


Link to post
Share on other sites
Shotaro I - Seagull Support

Good to hear worked partly - Besides for Win2008 R2 case I don't have a good clue.

I would uninstall BarTender suite, and try standard install.

(I assume you've tried that already - but, if not.)

Share this post


Link to post
Share on other sites
Markus

I haven't tried yet to reinstall because I didn't find the time (server is in productive use).

I have additionally installed Bartender Suite on a new Win2008 R2 server this week and Printer Maestro is working, but strange thing is that it always shows that printer jobs are canceled by users also they are printing fine. I have attached a screenshot from History Explorer and Printer Maestro. Any idea why it doesn't recognize the correct status? This canceled status seems to be shown for every print job and every connected printer, normal Canon printers and TSC label printers with Seagull driver.

post-1708-0-65849700-1329473812_thumb.jpg

Share this post


Link to post
Share on other sites
Gene H

Hello Markus,

 

In order to properly retrieve the print job status, you may need to have Advanced Printing Features disabled for the printer driver in question.

 

To disabled Advanced Printing Features:

 

1. Open the printers list from the Control Panel

2. Open the properties of the driver in question

3. Go to the Advanced Tab

4. Uncheck “Enable Advanced Printing Features”

 

Once you’ve done that, the correct status for that printer should be correctly logged.

 

Let me know if that helps.

Share this post


Link to post
Share on other sites
Markus

In order to properly retrieve the print job status, you may need to have Advanced Printing Features disabled for the printer driver in question.

 

Now it works, Thanks!

Share this post


Link to post
Share on other sites
enersysit

I'm having the same issue I have a fresh install of Windows server 2003 R2 SP2.

 

I installed the full Bartender 9.4 SR3 suite including the print maestro software.

 

The Software seems to be working ok however the service had fail to install.

 

I tried to install the service manually using the Maestro.Service.exe /install command and I get the same error

C:\Program Files\Seagull\BarTender Suite>Maestro.Service.exe/install

 

Running a transacted installation.

 

Beginning the Install phase of the installation.

Installing service Maestro...

Service Maestro has been successfully installed.

Creating EventLog source Maestro in log Application...

An exception occurred in the OnAfterInstall event handler of System.ServiceProce

ss.ServiceInstaller.

System.InvalidOperationException: Cannot start service Maestro on computer '.'.

The inner exception System.ComponentModel.Win32Exception was thrown with the fol

lowing error message: The service did not respond to the start or control reques

t in a timely fashion.

 

An exception occurred during the Install phase.

System.InvalidOperationException: An exception occurred in the OnAfterInstall ev

ent handler of System.ServiceProcess.ServiceInstaller.

The inner exception System.InvalidOperationException was thrown with the followi

ng error message: Cannot start service Maestro on computer '.'..

The inner exception System.ComponentModel.Win32Exception was thrown with the fol

lowing error message: The service did not respond to the start or control reques

t in a timely fashion.

 

The Rollback phase of the installation is beginning.

Restoring event log to previous state for source Maestro.

Service Maestro is being removed from the system...

Service Maestro was successfully removed from the system.

 

The Rollback phase completed successfully.

 

The transacted install has completed.

Installation Failed: An exception occurred in the OnAfterInstall event handler o

f System.ServiceProcess.ServiceInstaller.

 

 

I have checked my .Net versions and it looks like I have 2.0 with SP2 installed.

 

Thanks in advance for the help

Share this post


Link to post
Share on other sites
Markus

I'm having the same issue I have a fresh install of Windows server 2003 R2 SP2.

 

This did the trick for me (from http://social.msdn.microsoft.com/Forums/en-US/winserver2008appcompatabilityandcertification/thread/4f8fd6f4-f978-4478-ac15-a815d2e9ba1d/ ):

 

If it's a .Net app, you can try to change the State value and see if that helps. Found here:

HKEY_USERS\S-1-5-18\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing

 

Change it from 23c00 to 23e00 (this will disable the CRL check for the System account).

Share this post


Link to post
Share on other sites

×