Jump to content
JerryBarrett

Integration Builder (Commander) Print Problem

Recommended Posts

JerryBarrett

Hi

 

I found commander, its called Integration Builder :)

 

I have a label with a 2D barcode that prints perfectly when extracting data from an Excel file and after a new Database connection to a text file was configured the label prints from the Bartender UI.

 

I have a comma delimited file called mytest.dat. Which I tested from the Bartender UI satisfactorily.

 

However, when I switch on my Integration Builder tools -> test facility. It finds the file and triggers an event to print the same label I tested earlier in the UI, but I get an error indicating an error with the page setup dialogue.

 

If I return back into Bartender UI it all works perfectly :(

 

It seems if I can locate this error, I'm sure it would work, will you advise please?

 

many Thanks

Jerry

  • Like 3

Share this post


Link to post
Share on other sites
JerryBarrett

Hi

 

I just tried the same test from an Access Integration and while the label prints manually drawing data from Access to the Bartender UI..

 

If I switch on and link Integration Builder for Access, I get the same error  indicating  a page setup dialog issue?

 

I'm a bit confused now sorry, can I have some advise please :)

 

Jerry

Share this post


Link to post
Share on other sites
JerryBarrett

Hi

 

I have gone over the page print setup and I cant find any issues. When I print the labels from Bartender directly it works perfectly and by directly getting data from an excel spreadsheet and by getting the data directly from an Access Db

 

but from Access Db via Integration Builder it fails with this message;

 

Print job 'GS1-2D-AutoIntegration.btw' did not complete due to the following error: There is an error in the Page Setup dialog. Please fix the problem and try again.

 

I have no idea what's going wrong here, will you help me please?

 

Regards

Jerry Barrett

Share this post


Link to post
Share on other sites
JerryBarrett

Hi

 

I have tried to make a new label from scratch, while this label prints from Bartender directly

 

Using Integration Builder from Access fails with the same error.

 

Does this product actually work, no one seems to be able to offer any advice ? :((

 

Regards

Jerry Barrett

Share this post


Link to post
Share on other sites
Ian C - BarTender ninja @ Seagull

This is most likely caused by a printer driver being used to open the label, that you do not intend, and that just so happens to have incompatible page set-up capabilities.

 

Are you specifying the printer that you wish to open the document with, or are you just going with the default as specified in the document itself?  What is set in the document; is it using the "[defult]" printer, or did you specify a specific printer which will hold true no matter which Windows user opens the label?

Share this post


Link to post
Share on other sites
JerryBarrett

Hi

 

Thank you for your suggestion. But from what I can see the Bartender document has the printer specified a CL-S631

 

That's also specified in the printer setup dialog page, were you indicating I should be looking for the default printer elsewhere, another dialog?

 

I also specified the print section in the Integration Builder, still no change, the same error occurs :)

 

Regards

Jerry Barrett

Share this post


Link to post
Share on other sites
Ian C - BarTender ninja @ Seagull

Can you attach the files in question (BTW and BTIN) for me to examine?

Share this post


Link to post
Share on other sites
JerryBarrett

Hiya

 

Yes of course I think I attached the two files you wanted.

 

When I was in the Integration Builder theres a section about printing and a button to copy the printer details. I used that and removed some of the default copy values and it seemed to spring into life and I got a print.

 

There are some new script errors now which are a bit confusing as I said previously, it prints perfectly from the Bartender UI.

 

Any advise would be appreciated - thank you :)

 

Regards

Jerry

AccessIntegration.btin

GS1-2D-AutoIntegration.btw

Share this post


Link to post
Share on other sites
JerryBarrett

Hi

 

Wow, I got it working, I tinkered with the printer setting in the Integration Thingy and checked my scripts and I get a print and it appears no errors :)

 

(Big Grins)

 

Thank you for pointing me in the right direction.

 

Regards

Jerry Barrett

Share this post


Link to post
Share on other sites
Ian C - BarTender ninja @ Seagull

Okay great!  Good work.

Share this post


Link to post
Share on other sites
NickTu

I'm getting the exact same problem.  Can you share what you've done to fix this, please?
 
The label file prints fine within Bartender Automation, but gives this error when testing the BT file within Integration Builder.
 
   There is an error in the Page Setup dialog.  Please fix the problem and try again.
 

Attached are my btw and btin files.

Regards,
Nick

ReceiptLabel.btw

IntegrationFile.btin

Share this post


Link to post
Share on other sites
NickTu

Still struggling with this problem.  I've tried everything I can think of, but still no luck.  Any help is much appreciated.

 

Thanks,

Nick

Share this post


Link to post
Share on other sites
NickTu

I think I found the fix.  It's under the Print Option Overrides (in Actions/Print Command Script), the Prompt for data input has to be checked.

 

It's kind of strange because there are no inputs, other than what's in the BT file.

 

Anyway, that seems to allow the BT file to be printed without any more errors.

 

Nick

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

×